Menu
×
  • Main
  • Home
  • Network Monitoring Software
  • Application Monitoring Software
  • Bandwidth Monitoring Software
  • Syslog Servers
  • TFTP Servers
  • Event Log Analysis Software
  • Help Desk Software
  • IPAM Software
  • Netflow Analyzers and Collectors
  • Network Configuration Management Software
  • VN Manager & Monitoring Software
  • Wake On Lan Tools
  • Info & Contact
  • Contact
  • Terms of Use
  • Privacy Policy
  • Disclaimer
  • Legal
  • © 2016 NetAdminTools.com
    All Rights Reserved

Network Admin Tools

  • Home
  • Monitoring
  • Backup/Recovery
  • GNU/Linux
  • Administration
  • Perl
  • Ruby
  • Database

Determining 5 Flexible Single Master Operations (FSMO) Roles for Active Directory Domain Controller

Last Updated: September 28th, 2016 at 3:18 pm Paul Anderson

Review By Paul Anderson / September 28, 2016 — Network Services

Most domain controller functions replicate among the domain controllers in an Active Directory domain. There are five functions, though, that are not replicated. What this means is if you lose the domain controller that has the FSMO roles, then you need to do some recovery steps before your domain controllers replicate properly again. To determine […]

Removing the EXIFS Service

Last Updated: September 28th, 2016 at 3:18 pm Paul Anderson

Review By Paul Anderson / September 28, 2016 — Network Services

If you have remnants of Exchange 2000 on Windows Server 2003, even after an uninstall of Exchange, you may get warnings about the IFS driver. The Exchange Installable File System (ExIFS) exposes bits of the Exchange information store via the file system. Running Exchange 2000 on Windows Server 2003 is not supported by Microsoft and […]

Chef, Systems Center 2012, and Cloud

Last Updated: May 11th, 2018 - Paul Anderson

Review By Paul Anderson / May 11, 2018 — Network Services

Microsoft is starting to get it with Systems Center 2012, but if you haven’t followed Chef, check out this concise perspective by the folks that blazed this trail: Now, one might *think* that this is a structural fork in the road, and Microsoft is on a different (but similar) road, but this isn”t necessarily so. […]

Subnet Reference Guide + Perl script to generate it

Last Updated: October 30th, 2017 - Paul Anderson

Review By Paul Anderson / October 30, 2017 — Networking

Here is our subnet reference guide and The Perl script used to generate it If you want an easy to use subnetting calculator, Subnet-Calculator.org is one of the best ones we’ve seen online. Subnet Reference Guide — Value of individual bits in an eight bit byte if true: Bit 7 = 128 Bit 6 = […]

Latency Tips

Last Updated: May 11th, 2018 - Paul Anderson

By Paul Anderson / May 11, 2018 — Networking

If you have a WAN, then one very important concern should be latency. Latency, in this case, is the time that a package of information takes to reach the other end of the slow link. This package of information could be a DNS query, ping, file, or a transaction in a client/server application. Notice that […]

Cisco IOS Upgrade

Last Updated: March 8th, 2018 - Paul Anderson

By Paul Anderson / March 8, 2018 — Networking

There are some nasty, nasty SNMP vulnerabilities that have recently been revealed. Many different products are affected. See the CERT Advisory Here. This inspired us to upgrade our Cisco. To upgrade the IOS on your Cisco router, you have a couple of options. You can either upgrade via TFTP, or you can use the console. […]

Recycling a Watchguard Firebox FB10

Last Updated: May 11th, 2018 - Paul Anderson

By Paul Anderson / May 11, 2018 — Networking

We picked up a Watchguard Firebox FB-10R from RE-PC (Tukwila) for 15 bucks. There is almost always some kind of auction on Ebay selling a Firebox FB-10. The motherboard on ours, it turns out, was damaged. Now the Firebox FB-10R is just a regular PC clone. It has three 3COM 3C509 NICs in it. We […]

Installing a TFTP Server on Red Hat 8.0

Last Updated: March 8th, 2018 - Paul Anderson

By Paul Anderson / March 8, 2018 — Networking

In this story we showed how to upgrade IOS on a Cisco using a TFTP server available from Cisco that ran on Windows. Well, just suppose you wanted to load a new IOS image from a TFTP server on a GNU/Linux box. We will use Red Hat 8.0 to provide a TFTP server. First, install […]

Firewall on a Floppy

Last Updated: October 3rd, 2016 - Paul Anderson

By Paul Anderson / October 3, 2016 — Networking

Check out floppyfw for a simple firewall and IP sharing device. No hard drive is needed, and 16 megs of RAM is more than enough. The instructions on the site and in the comments in the config files are quite easy to follow. One somewhat tricky problem is if you are using a network card […]

Some Useful RFCs

Last Updated: October 3rd, 2016 - Paul Anderson

By Paul Anderson / October 3, 2016 — Networking

HTTP: RFC 2068 POP3: RFC 1725 SMTP: RFC 821 FTP: RFC 959

Installing Network Probe

Last Updated: May 11th, 2018 - Paul Anderson

By Paul Anderson / May 11, 2018 — Networking

Network Probe is a free network monitor and protocol analyzer that runs on Windows NT/2K/XP, Linux, FreeBSD, Solaris (Intel), and Mac OS X. We downloaded the Linux version by filling out the form here. The form wasn’t too intrusive, and the email with the download information came back quickly. We used version 0.4 for this […]

Setting Up Network Load Balancing on Windows 2000 Advanced Server

Last Updated: May 11th, 2018 - Paul Anderson

By Paul Anderson / May 11, 2018 — Networking

Network load balancing is a service that comes with Windows 2000 Advanced Server (not plain old Windows 2000). In this article we will set up Network Load Balancing on a cluster of two systems and test via the telnet service. The Network Load Balancing service is unlike other popular load balancing schemes like Red Hat […]

Using the WLBS CLI tool to Control Network Load Balancing on Windows 2000 Advanced Server

Last Updated: October 3rd, 2016 - Paul Anderson

By Paul Anderson / October 3, 2016 — Networking

In order to use the WLBS CLI, you need to enable remote control: The WLBS CLI lives as wlbs.exe in system32. Query the cluster: C:\>wlbs query 10.50.100.10 /passw WLBS Cluster Control Utility V2.3. (c) 1997-99 Microsoft Corporation Password: Accessing cluster ‘10.50.100.10’ (10.50.100.40): Host 7 (10.50.100.17) reported: converged Host 1 (10.50.100.11) reported: converged as DEFAULT Host […]

Initial MRTG Configuration

Last Updated: May 11th, 2018 - Paul Anderson

By Paul Anderson / May 11, 2018 — Networking

MRTG is a monitoring tool for traffic loads on network-links. It will create HTML pages with visual representation of both the current and historical load on the device. The server we will use for this article is the Gentoo box we built in this article. With Gentoo, we simply run emerge and a bunch of […]

Creating a PPP Connection to a Cisco Aux Port

Last Updated: September 8th, 2021 - Paul Anderson

By Paul Anderson / September 8, 2021 — Networking

In this article, we set up MRTG to monitor an old Cisco 1720 router. Now, it is nice to have *two* interfaces on a lab router so that you can route between two physical interfaces. We tried adding a second FastEthernet module instead of the T1 module we have, but the firmware was too old. […]

Using the Ping -f Option to Test for Lost Packets

Last Updated: October 3rd, 2016 - Paul Anderson

By Paul Anderson / October 3, 2016 — Networking

There is a cool option on some versions of ping. With the -f option, a dot is printed for each ping sent, and a backspace is printed when a ping is received. This gives you an instant visualization of the lost packets. Hit ctrl-c to end the task, and you will then see the latency […]

AreWeDown Trace/Latency Tool

Last Updated: May 11th, 2018 - Paul Anderson

By Paul Anderson / May 11, 2018 — Networking

We wrote up a tool that will generate a latency and trace report based on your IP address. Note that this is the IP address that the web server detects your client has. First it pings your IP address with 50 pings or 5 seconds worth of pings, whatever is the most restrictive. If 50 […]

Solving Network Congestion Issues With Cisco Traffic Shaping

Last Updated: September 8th, 2021 - Paul Anderson

By Paul Anderson / September 8, 2021 — Networking

In this article we will show how to monitor network health from the client perspective using our AreWeDown tool. We will then disrupt communication from the client perspective to the server by using a ping flood, and will solve the problem using traffic shaping. Let’s start out with a healthy network: | 2005-08-06 08:13:50 | […]

Converting a Rails App to present with GTK

Last Updated: October 26th, 2023 - Paul Anderson

By Paul Anderson / October 26, 2023 — Ruby

This article shows how to convert a Rails application to a standard Ruby application, and it shows how to present the data via GTK2. The idea is that a web application and a desktop application can have similar needs, and going back and forth via a common framework has some advantages. We are taking this […]

Ruby Regex Substitution – Benefit of Controllers

Last Updated: October 3rd, 2016 - Paul Anderson

By Paul Anderson / October 3, 2016 — Ruby

This site is generated on RoR, but published as static HTML. It goes way, way back, and the images are referenced in many ways. I think there is a decent chance that some images are referenced without quotes. I added a feature for mobile views years ago, so that I could easily browse with my […]

« Previous Page
Next Page »

Search

Must Read Resources

  • WHITE PAPER
    Network Management Software Buyers Guide
  • WHITE PAPER
    GNS3 Network Emulator Training
  • WHITE PAPER
    Netflow Best Practices
  • WHITE PAPER
    Learn how to Analyze Packet with Deep Analysis
  • WHITE PAPER
    How to Find your Highest Bandwidth Users
Network Admin Tools
Network Admin Tools

Categories

  • Active Directory
  • Administration
  • Backup/Recovery
  • BSD
  • Bugs and Fixes
  • Certification
  • Comparisons
  • Database
  • Desktop
  • DIY
  • Email
  • ERP
  • File/Print
  • GIAGD
  • GNU/Linux
  • GNU/Linux Dictionary
  • Hardware
  • Information Grab Bag
  • Interoperability
  • Monitoring
  • Name Resolution and DNS
  • Network Management Software
  • Network Services
  • Networking
  • Perl
  • REALbasic
  • Remote Control
  • Ruby
  • Security
  • Software
  • Solaris
  • Syslog Servers
  • TFTP Server
  • Uncategorized
  • Web
Network Admin Tools
Network Admin Tools

Information

  • Contact
  • Privacy Policy
  • Terms of Use
  • Disclaimer
  • Legal

About

  • About Us
  • Contribute
  • Staff/Authors

© 2026 Network Admin Tools · Powered by Leanpress